Tags: ase, backup, database, error, installed, mysql, oracle, running, server, sql, sybase, windows

ASE 12.0 Backup server will not start.

On Database » sybase

3,240 words with 12 Comments; publish: Thu, 01 Nov 2007 11:46:00 GMT; (25078.13, « »)

I have installed ASE 12.00 on a server running windows NT. I am not able to start the Backup Server; keeps getting error "the server could not be started". I have been working with Sybase for a couple weeks now and still cannot seem to resolve this. If any one is familiar with this, I would greatly appreciate some troubleshooting advice.

Thanks.

All Comments

Leave a comment...

  • 12 Comments
    • What is in the error log? For both ASE and Backup Server.
      #1; Thu, 13 Dec 2007 12:47:00 GMT
    • The error reads: " The service SYBBCK_SERVERNAME_BS could not be started. Please check the configuration" I have uninstalled in reinstalled several times. When I attempt to start the service from Control Panel I get the following error: "Could not start the Sybase BCKserver_Severname_bs , Error 1067: the error terminated unexpectedly"
      #2; Thu, 13 Dec 2007 12:48:00 GMT
    • Sorry, I accidently hit send before I send you the actual error from the log. From ASE: The only error referred to the XP server it reads:

      Error: 7221, Severity: 14, State: 2

      server Login to site 'NYSYBASE3_XP' failed.

      XP Server could not be stopped because shutdown RPC could not be completed. Check to see if there is XP Server process running, and kill this process if it is running.

      from the Backup:

      Network error: status = 23 - Net-Lib protocol driver call to register a listener failed

      Open Server Server Fatal Error: 16029.20.0: Failed to start any network listeners

      .

      #3; Thu, 13 Dec 2007 12:49:00 GMT
    • What is the IP address and name of the machine? What is the contents of your INTERFACES file (or SQL.INI).
      #4; Thu, 13 Dec 2007 12:50:00 GMT
    • Server name NYSYBASE3

      IP: 10.213.167.66

      #5; Thu, 13 Dec 2007 12:51:00 GMT
    • Lynn do you have the contents of the INTERFACES file or the SQL.INI?

      Interfaces should look something like this:

      NYSYBASE3

      master tcp ether 10.213.167.66

      NYSYBASE3_BACKUP

      etc.

      What is the name and IP of the backup server?

      #6; Thu, 13 Dec 2007 12:52:00 GMT
    • Hi Mark,

      This is the contents of the entry for the backup server from the SQL.INI

      [NYSYBASE3_BS]

      MASTER=NLWNSCK,nysybase3,10.213.167.66

      QUERY=NLWNSCK,nysybase3,10.213.167.66

      #7; Thu, 13 Dec 2007 12:53:00 GMT
    • Second thought why don't I just attached the file
      #8; Thu, 13 Dec 2007 12:54:00 GMT
    • In the UNIX world you have to specify a port to listen on. The 16029.20.0 error write-up signifies backup server is either already running or the port is in use. If you haven't specified a port I'd think that error would pop up.
      #9; Thu, 13 Dec 2007 12:55:00 GMT
    • I did try both; with and without port numbers, but got similiar messages. The file I sent was with the port number removed. I readded the port number, but nothing changed.
      #10; Thu, 13 Dec 2007 12:56:00 GMT
    • did u get this problem resolved? i'm having a similar problem. i just installed ase 12.5 on our win2000 server. i need to move everything fr our 11.5 to 12.5. i'm in the middle of the master recovery. i get real stuck at load master. it keeps saying the backup server is having problem, but i checked interfaces, sysservers, and Services. they all looked alrite to me.
      #11; Thu, 13 Dec 2007 12:57:00 GMT
    • HI,

      This is a lot different from the problem that I was having. My BCK_SEVER was not showing when I run Sysservers. After checking my remote server in Sybase Central I notice that I did not show their either. I just readded it and it is not functional.

      Good luck on this, and I would like to know how this is resolved since I have to migrate from 11 - 12.5 in the fall.

      #12; Thu, 13 Dec 2007 12:58:00 GMT